Cisco sviçlərdə makrosun konfiqurasiyası və tətbiqi

Cisco sviçlərdə makrosun konfiqurasiyası və tətbiqi
Fontu böyüt (A+) / Fontu kiçilt (A-)

Salam,

Cisco sviçlərdə eyni əmrləri bir neçə interfeysə tətbiq etmək üçün hər dəfə interfeys moda daxil olub, əmrləri yazmaq lazımdır. Məsələn, 20 interfeysə eyni əmrləri daxil etmək üçün ya hər bir interfeysə bir-bir daxil olmaq, ya da interface range əmrindən istifadə edərək, əmrləri bir-bir daxil etmək tələb olunur. Bu işi asanlaşdırmaq üçün makroslardan istifadə etmək olar.

1. Makrosu yazın:

Switch>enable

Switch#configure terminal

Switch(config)#macro name TEST

Enter macro commands one per line. End with the character “@”.

switchport mode access

switchport access vlan $V

spanning-tree portfast

@

Switch(config)#

 

Qeyd: @ simvolu makrosun sonunu bildirir.

2. Makrosu interfeysə tətbiq edin:

Switch(config)#interface range gigabitEthernet 0/1 – 20

Switch(config-if)#macro trace TEST $V 20

Applying command… “switchport mode access”

Applying command… “switchport access vlan 20″

Applying command… “spanning-tree portfast”

%Warning: portfast should only be enabled on ports connected to a single host. Connecting hubs, concentrators, switches, bridges, etc… to this interface  when portfast is enabled, can cause temporary bridging loops. Use with CAUTION

%Portfast has been configured on GigabitEthernet0/24 but will only have effect when the interface is in a non-trunking mode.

3. Konfiqurasiyanı yoxlayın:

Switch#show running interface gigabitEthernet 0/5

Building configuration…
!

interface GigabitEthernet0/24

switchport access vlan 20

switchport mode access

macro description TEST

spanning-tree portfast

end

 

Switch#show running interface gigabitEthernet 0/20

Building configuration…

!

interface GigabitEthernet0/20

switchport access vlan 20

switchport mode access

macro description TEST

spanning-tree portfast

end

4. İnterfeysi ilkin konfiqurasiyaya (default) qaytarmaq üçün aşağıdakı əmri daxil edin:

Switch(config)#default interface gigabitEthernet 0/20

5. İnterfeysin ilkin konfiqurasiyaya qayıdıb-qayıtmadığını yoxlayın:

Switch#show running-config interface gigabitEthernet 0/20

Building configuration…

Current configuration : 37 bytes

!

interface GigabitEthernet0/20

end

 

Uğurlar!

Amal
CCNA/CCNP/CCNA Security

Nele Neuhaus - Unter Haien

  Alman yazıçısı Nele Noyhausun (Nele Neuhaus) bestseller olmuş növbəti ...

Daha ətraflı

Jo Nesbo - The Son

  Norveç yazıçısı Yu Nesbonun (Jo Nesbo) bestseller olmuş növbəti ...

Daha ətraflı

EEM proqramlaşdırma – mərkəzi prosessordakı sıçrayışlar

Salam, Şirkətdə idarə etdiyim Cisco Systems istehsalı olan 3750 sviçin mərkəzi ...

Daha ətraflı

Cisco Kursları

Cisco Certified Network Associate (CCNA R&S) kursu – CCNA 5.0 Dünyada şəbəkə ...

Daha ətraflı

RIP (Routing Information Protocol) – 1-ci hissə

Salam, Routinq protokollar dedikdə statik və dinamik routinq protokollar yada düşür. ...

Daha ətraflı