RIPv2 routinq protokolunda offset-list əmri

RIPv2 routinq protokolunda offset-list əmri
Fontu böyüt (A+) / Fontu kiçilt (A-)

Salam,

RIPv2_offset-list_topology

 

Şəkildəki topologiyada R1 adlı router 10.10.10.0/24 şəbəkəsini R3 adlı routerdan RIPv2 routinq protokolu vasitəsilə serial xətt üzərindən öyrənir. Çünki RIPv2 routinq protokolu ən yaxşı routun seçilməsi prosesində metrik olaraq hop sayını əsas götürür. Göründüyü kimi R1 adlı routeri 10.10.10.0/24 şəbəkəsinə R3 adlı routerdən 1 hop (R3), R2 adlı routerdən isə 2 hop (R2, R3) keçərək çatır. Ən az hop sayını nəzərə alaraq, R1 adlı router 10.10.10.0/24 şəbəkəsini R3 adlı routerdan öyrənir. Topologiyaya diqqət yetrisək, görərik ki, R1 adlı router ilə R3 adlı router arasında əlaqə serial xətt vasitəsilə təmin olunur. İlkin olaraq, serial xəttdə sürət 1,5 Mbps olur. R1 adlı router ilə R2 adlı router və R2 adlı router və R3 adlı router arasında isə əlaqə fastethernet texnologiyası vasitəsilə təmin edildiyinə görə ilkin sürət 100 Mbps-dir. Sürət faktorunun şəbəkədə vacib element olduğunu nəzərə alaraq, deyə bilərik ki, R1 adlı router 10.10.10.0/24 şəbəkəsinə  sürətin az olduğu rout vasitəsilə çatır. Offset-list əmrindən istifadə edərək, daha sürətli routu işə salaq və problemi həll edək. İlk olaraq, bütün routerlarda konfiqurasiyalara baxaq.

 

R1>enable

R1#configure terminal

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)exit

R1(config)#interface Serial0/0

R1(config-if)#ip address 192.168.2.1 255.255.255.0

R1(config-if)#clock rate 2000000

R1(config-if)#no shutdown

R1(config-if)exit

R1(config)#router rip

R1(config-router)#version 2

R1(config-router)#network 192.168.1.0

R1(config-router)#network 192.168.2.0

R1(config-router)#no auto-summary

 

R2>enable

R2#configure terminal

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 192.168.3.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)exit

R2(config)#interface FastEthernet0/1

R2(config-if)#ip address 192.168.1.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)exit

R2(config)#router rip

R2(config-router)#version 2

R2(config-router)#network 192.168.3.0

R2(config-router)#network 192.168.1.0

R2(config-router)#no auto-summary

 

R3>enable

R3#configure terminal

R3(config)#interface FastEthernet0/0

R3(config-if)#ip address 192.168.3.3 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)exit

R3(config)#interface FastEthernet0/1

R3(config-if)#ip address 10.10.10.3 255.255.255.0

R3(config-if)#no shutdown

R3(config-if)exit

R3(config)#interface Serial0/0

R3(config-if)ip address 192.168.2.3 255.255.255.0

R3(config-if)clock rate 2000000

R3(config)#router rip

R3(config-router)#version 2

R3(config-router)#network 10.0.0.0

R3(config-router)#network 192.168.2.0

R3(config-router)#network 192.168.3.0

R3(config-router)#no auto-summary

 

R4>enable

R4#configure terminal

R4(config)#interface FastEthernet0/0

R4(config-if)#ip address 10.10.10.4 255.255.255.0

R4(config-if)#no shutdown

R4(config-if)exit

R4(config-router)#version 2

R4(config-router)#network 10.0.0.0

R4(config-router)#no auto-summary

R1 adlı routerda show ip route əmrinin köməyilə routinq cədvələ baxaq.

 

RIPv2_offset-list_show_ip_route

Göründüyü kimi R1 adlı router 10.10.10.0/24 şəbəkəsini R3 adlı routerdən serial xətt vasitəsilə öyrənir. R3 adlı routerda offset-list əmrindən istifadə edərək,  R1 adlı routerin 10.10.10.0/24 şəbəkəsini daha sürətli fastethernet xətti vastəsilə öyrənməsini məcbur edək.

R3(config)#router rip

R3(config-router)#offset-list 0 out 3 serial 0/0

0 – R3 adlı routerin göndərdiyi bütün routlar mənasını verir. Bütünlükdə əmrin mənası odur ki, R3 adlı routerun serial 0/0 interfeysindən göndərilən bütün routların metriki 3 hop olacaq. Beləliklə, R1 adlı router 10.10.10.0/24 şəbəkəsini R3 adlı routerin serial interfeysindən 3 hop metriki ilə, R2 adlı routerdan isə 2 hop metriki ilə alır. Metriki az olan routa üstünlük verildiğinə görə 10.10.10.0/24 şəbəkəsinə rout R2 adlı routerdan olacaq.

R1 adlı routerda show ip route əmrinin köməyilə routinq cədvələ baxaq.

RIPv2_offset-list_show_ip_route_with_offset_list_command

 

 

CCNA kursu 5.0 – 200-120

 

 

Uğurlar!

Amal

CCNA/CCNP/CCNA Security/CCAI

EEM proqramlaşdırma – mərkəzi prosessordakı sıçrayışlar

Salam, Şirkətdə idarə etdiyim Cisco Systems istehsalı olan 3750 sviçin mərkəzi ...

Daha ətraflı

Cisco Kursları

Cisco Certified Network Associate (CCNA R&S) kursu – CCNA 5.0 Dünyada şəbəkə ...

Daha ətraflı

RIP (Routing Information Protocol) – 1-ci hissə

Salam, Routinq protokollar dedikdə statik və dinamik routinq protokollar yada düşür. ...

Daha ətraflı